#show ip route

show ip route


Displays the entire IP route table, a summary of the routing table or route information for specific IP addresses, network masks or protocols.
Syntax: show ip route [[ipAddress [mask]] [bgp | connected | mpls [ipAddress] [ipAddress/PrefLen] [ipAddress mask] [detail] | isis | ospf | static | summary | multicast |unicast]

ipAddress
Specify an IP address for the IP routes to display.
mask
Specify an IP address mask for the specified IP address.
PrefLen
Specify a Prefix Length for the specified IP address. Valid values = 0 - 31.
Description: Use the show ip route command with no arguments to display all IP routes.
Use the show ip route command with the address argument to display routes to a specific IP address.
Use the show ip route command with the mask argument to display routes with a specific network mask.
Use the show ip route command with the bgp, isis, ospf keyword to display summary information about all routes for the specified protocol.
Use the show ip route multicast command to display active routes used by Multicast protocols.
Use the show ip route unicast command to display active routes used for unicast forwarding.
Use the show ip route connected command to display summary information about all directly connected routes.
Use the show ip route mpls command to display all tunnel related route statistics.
use the show ip route mpls detail to display detailed information of all the tunnels by which each route/prefix is reachable. The detail keyword can optionally be used with all ipAddress variants of mpls.
Use the show ip route static command to display summary information about all statically configured routes.
Use the show ip route summary command to display summary information about all IP routes.
Factory Default: None.
Command Mode: Executive and privileged.
Example 1: In the following example, the show ip route command with no arguments displays all routes:


router>show ip route

Codes: C - connected O - OSPF i - IS-IS

S - static UD - Up/Down bit 1 L1 - level-1

B - BGP E1 - external type 1 L2 - level-2

M - MPLS E2 - external type 2

* - candidate default

m - route's metric

d - administrative distance

S * 0.0.0.0/0 via 10.200.0.1 [d:1 m:0]

S 9.9.9.9/32 via 127.0.0.1 [d:1 m:0]

C 10.200.0.0/16 directly connected to Ethernet 0

i UD 12.2.41.19/32 via 55.55.55.1 [d:115 m:35]

i UD 12.2.41.20/32 via 55.55.55.1 [d:115 m:35]

i UD 12.2.41.21/32 via 55.55.55.1 [d:115 m:35]

i UD 12.2.41.22/32 via 55.55.55.1 [d:115 m:35]

i UD 12.2.41.23/32 via 55.55.55.1 [d:115 m:35]

.

.

.

C 55.55.55.0/24 directly connected to GBE 1/19/2

C 55.55.55.3/32 directly connected to Null 0

S 127.0.0.0/8 via 127.0.0.1 [d:0 m:0]

C 127.0.0.1/32 directly connected to Null 0

i L1 191.191.191.191/32 via 55.55.55.1 [d:115 m:28]

i L1 191.194.1.0/24 via 55.55.55.1 [d:115 m:28]

C 193.193.193.193/32 directly connected to Loopback 0

i L1 194.10.1.0/24 via 55.55.55.1 [d:115 m:28]

C 194.10.2.0/24 directly connected to POS 1/14/2

C 194.10.2.1/32 directly connected to POS 1/14/2

C 194.10.2.2/32 directly connected to Null 0

S 200.1.1.0/24 via 127.0.0.1 [d:1 m:0]

S 200.1.2.0/24 via 127.0.0.1 [d:1 m:0]

S 200.1.3.0/24 via 127.0.0.1 [d:1 m:0]

.

.

.



The following table describes the fields displayed by the show ip route command.

Table 1-8. Fields Displayed by show ip route 
Field Description
connected
Specifies the route was learned as a result of configuring the interface.
static
Specifies the route was explicitly configured using the ip route command.
BGP
Specifies the route was received from BGP protocol advertisements.
MPLS
Specifies this route carries MPLS data.
external type 1
Specifies the route was imported into the OSPF area from an Autonomous System Boundary Router (ASBR). Further, this route used the cost associated with the link between the ASBR and this router as part of the cost of the route.
external type 2
Specifies the route was imported into the OSPF area from an Autonomous System Boundary Router (ASBR). Further, this route does not use the cost associated with the link between the ASBR and this router as part of the cost of the route.
isis
Specifies this route was received from IS-IS protocol advertisements.
N.N.N.N/nn
Network address and mask of the remote network.
via N.N.N.N
Indicates the next router in the remote network.
directly connected to
Indicates the network is directly connected to a local interface.
UD
Indicates the Up/Down bit is set and that the route was leaked from L2 into L1.
d:
The administrative distance assigned to this route.
m:
The metric assigned to this route.
Example 2: In the following example, the show ip route static command displays information about statically configured routes:


router>show ip route static

S 0.0.0.0/0 via 10.5.0.1 [w:1 m:0]

S 127.0.0.0/8 via 127.0.0.1 [w:0 m:0]

S 131.1.1.0/24 via 127.0.0.1 [w:1 m:0]

S 131.1.2.0/24 via 127.0.0.1 [w:1 m:0]

S 131.1.3.0/24 via 127.0.0.1 [w:1 m:0]

S 131.1.4.0/24 via 127.0.0.1 [w:1 m:0]

Example 3: In the following example, the show ip route summary command displays summary information about all IP routes:


router#show ip route summary



Route source Networks

connected 12

static 2

bgp 100654

ospf intra-area 1785

total 102453

The following table defines the fields displayed in the show ip route summary command:

Table 1-9. Fields Displayed by show ip route summary 
Field Description
connected
These routes were learned as a result of configuring the interface
kernel
These routes were in the kernel before the routing task started running.
static
The number of routes that were explicitly configured using the ip route command.
bgp
The number of routes received from BGP protocol advertisements.
ospf intra-area
The number of routes learned from within this area.
ospf inter-area
The number of routes received from other OSPF areas.
ospf external-1
These routes were imported into the OSPF area from an Autonomous System Boundary Router (ASBR). Further, these routes use the cost associated with the link between the ASBR and this router as part of the cost of the route.
ospf external-2
These routes were imported into the OSPF area from an Autonomous System Boundary Router (ASBR). Further, these routes do not use the cost associated with the link between the ASBR and this router as part of the cost of the route.
isis
The number of routes received from IS-IS protocol advertisements.
total
The total number of routes in the IP route table.
Related Commands: ip address
ip route

Voice Interview Questions



A phone has a device CSS that includes the partitions phones and PSTN. This provides access
for all internal phones and external calls. The first line on this phone has a CSS that includes the
partitions phones, 911, and local. If a call is placed to a long-distance number, will the call be
completed and why or why not?
Yes, because the call will use the device CSS


When creating your own CSV file to be used by Cisco Unified Communications Manager BAT,
which three rules do you need to follow? 
1. Edit the Excel macro for each separate Unified Communications Manager BAT transaction.
2. Use a separate line for each data record.
3. Separate each data field with a comma and include comma separators for blank fields.

There are three servers listed in a Cisco Unified Communications Manager group. They are listed
in this order: Subscribe_1, Publisher, and Subscriber_2. In which order does an IP phone attempt
to register with the Cisco Unified Communications Manager group?
The IP phone will go through the list from first server to last server listed in the Cisco Unified
Communications Manager group list.

Which two call-routing tools can be applied to a device pool? (Choose two.)
1. Called and Calling Party Transformation CSS
2. Standard Local Route Group

What is required to configure NTP on a Cisco Unified Communications Manager publisher to
support SIP phones?
Configure Phone NTP References in Cisco Unified CM Administration.
 
Which layer of the Cisco Unified Communications components is responsible for delivering a dial tone?
Call control is the CUCM component responsible for delivering a dial tone.

What is the name of the server in a CUCM cluster that maintains a read/write copy of the entire database?
Publisher is the name of the server in a CUCM cluster that maintains a read/write copy of the entire database.

What protocol is responsible for transporting voice over IP?
Real-Time Transport protocol (RTP) is responsible for transporting voice over IP.

How many call-processing agents can be active in a CUCM cluster?
There are 4 call-processing agents that can be active in a CUCM cluster.

How many servers can be in a CUCM cluster?
There can be 20 servers in a CUCM cluster.

Which CUCM server is the license manager component active on?
The license manager component is active on all servers.

Which CUCM server is the license server component active on?
The license server component is active on the publisher server.

On which server in the CUCM cluster are license files loaded?
Publisher License files are loaded on the publisher server.

Which of the following features is not a user-facing feature (UFF)?
Attendant console (login/logout) is not a user-facing feature (UFF).

What is CUCM Clustering and its types.
The clustering feature of Cisco Call Manager provides a mechanism for seamlessly distributing call processing across the infrastructure of a converged IP network. Clustering provides transparent sharing of resources and features and enables system scalability
1.Single Site
2.Multisite with Centralized Call-Processing
3.Multisite with Distributed Call-Processing

4.Clustering Over the IP WAN

What is Clustering Over WAN.


3- Difference between MGCP and H323 gateway.


4- Diff between SIP/MGCP/h323

 
H.323 and SIP are both referred to as “call control” protocols. They allow a device, such as a desk phone, softphone, or videoconferencing system to place a call to another person over IP. 5- Media Resources- how to configure them. Transcoders, MTP.

6- Difference between Location and Region tab, Device pool, Codec.


7- Difference between Translation and Transformation pattern.


8- Feature sets- Hunt Group, Pick up group, shared lines, barge in, Privacy


9- Gatekeeper- Registration msgs, registering gateways via diff technologies, roles of GK/ Gateway- Advantages of MGCP and H323, MGCP backhaul.


10- Extension mobility, QOS


11- Difference between SRST and MGCP Fallback.


12- ISDN, RTP, RTCP etc.


13- What is a partition?


14- What is a CSS?


15- How are partitions and CSSs used in the dial plan?


16- I have all the phone numbers within my organization in the same partition. How can I grant the phone access to call these numbers?


17- My phone has a line CSS and a Device CSS. I have the same exact pattern in a partition in my line CSS and in a partition in my Device CSS. Which pattern takes precedence?


18- So if a call is permitted on the line CSS but blocked on the device CSS is the call routed or blocked?


19- What is Cisco’s Line / Device CSS methodology? If you are not familiar with it no need to answer.


20- The partition which contains all of my organizations phone numbers could either be placed in a CSS on the line or a CSS on the phone (device). Which one should I use and why?


21- What is a Local Route group and how does it simplify an implementation?


22- I want to identify four different classes of service for International, National, Local, Internal Only. Can give me a quick overview as to how I can apply a local Class of Service restriction on a phone?


23- Another engineer tells you that he plans to partition the phones logically according to the physical state (i.e. California) that they are located in. All the phones in the same state will be placed in the same device pool. He then asks you if this is how you would assign phones to a device pool. What do you think?


24- What is the difference between a region and a location?


25- When do you need to use DSPs?


26- Can you have a conference bridge without the use of DSPs?


27- What limitations are there to software based conference bridges?


28- How do I make sure all parties are using G711


29- What is the most obvious first step I should take to troubleshoot media resources?


30- How is a hardware based conference bridge configured and applied to a phone? Start with DSPs in your explanation and end with a phone being able to successfully join a conference bridge using a g.729 codec.



31- My H.323 gateway registration shows as Unknown in call manager. What should I do?


32- I am not sure if my PRI is coming up correctly. Is there a frequently used show command that will allow me to know / see if layer 1, 2 and 3 is currently up and working on my PRI.


33- What output from show ISDN status will allow me to know that my layer 3 connection to the telco has been successful?


34- I am getting TEI_ASSIGNED instead of MULTIPLE_FRAME_ESTABLISHED how might I solve this problem?


35- Which debug command will allow me to see what digits I am sending to or receiving from the telco on a PRI?


36- I need a show command that will allow me to troubleshoot clocking on my PRI. Perhaps I misconfigured my clocking and I might be getting errors on my PRI?


37- I have two different dial peers. One for 911 and another for [2-9]…… another engineer tells me that I need to use the command forward-digits all under my dial peer configurations. Is this command really necessary? Which dial peer will this command affect and what does this command do?


38- How can I tell if my MGCP gateway is registering correctly with Call Manager?


39- My MGCP gateway interfaces will not register with call manager what are some of the things I should check first as common errors people make?


40- Another engineer tells me I need to add ISDN bind-l3 ccm-manager to my gateway configuration. What does the following command do and where is it placed? What happens if I fail to add it?


41- When my MGCP gateway goes into SRST mode I notice that ISDN bind-l3 ccm-manager disappears from my configuration. Why is that?


42- If I have configured my Cisco Voice gateway with MGCP do I need to configure any translation-rules or dial peers on the gateway?


43- I have decided I am not going to use any transformation patterns in CUCM in any of my implementations. My users dial 9 for an outside line followed by 7 digits for local calls. Telco wants 10 digits for local. What then do I need to do in order to assure that TELCO accepts my calls?


44- At what layer of the OSI layer model does SIP signaling take place


45- How does NAT cause problems with SIP signaling? How does a CUBE solve these types of problems?


46- What is the difference between medial flow through and media flow around modes? If I am joining two 

different companies into one company which method should I use and why?

47- In Call Manager under Device > Trunk > Trunk Configuration I see a box that says: Media Termination Point Required what happens when I check that box? If I check that box and my calls fail why might this be happening? What is required between trunk endpoints for that box to be left unchecked?


48- I need to implement remote sites taking into consideration the dial plan, site features and options, how features and options match up with how the business uses their phone system. What questions do I need to ask to create a list of items that must be implemented for remote sites? The cluster is already built out so only focus on items that meet business requirements for remote sites. Please limit your response to 3 minutes. Example = pickup groups


49- Difference between h323 / MGCP /SCCP /SIP


50- Difference between CUCM / CME


51- Difference between FXS and FXO


52- Difference between T1/E1 PRI and T1/E1 CAS


53- Difference between 7940 / 7960 Ip Phone


54- What is MOH


55- Which codec is using on LAN / WAN


56- Bandwidth require for Voice Call on WAN


57- How many channels are in physical IP Phone


58- What are the Steps to add a H323 Device


59- What are the Steps to add a MGCP Device


60- What are different process running on call manager for registration.


61- What is new on CCM 4 5 CUCM 6 and 7


62- Is CLID supported by H323 and MGCP


63- Steps to add a Fractional T1 on system.


64- Steps to Configure Extension mobility.


65- Steps to configure IPMA.


66- what are all the Debug commands available for all voice protocols


67- Steps to integrate Unity with Call manager and verify the integration


68- Exchange integration with Unity


69- What is partition and CSS


70- How to integrate UCCX and using which protocol


71- What is cluster


72- What is publisher


73- Difference between SNR and MVA


74- Difference between FXS and FXO


75- Difference between and T1/E1 CAS


76- H323 call flow


77- SIP call flow


78- Early offer and delay offer


79- Types of call processing models in cisco ip telephony


80- Can we have SCCP gateway


81- What are the Steps to add a MGCP Device


82- Difference between call handler and user


83- H323 DTMF relay options


84- Steps to Configure MVA


85- what are all the Debug commands available for all voice protocols


86- Difference between h323 and MGCP


87- Why we need transcoder


88- How to add a user in CM


89- What you know about UCS Servers?


90- What’s new in CUCM 9?


91- Configure VLAN


92- Voice VLAN is trunk or access


93- In ether switch module does it required to put switch mode access?


94- Does VLAN can be made as trunk?


95- IP Phone Bootup Process.


96- SIP firmware updating


97- SIP phone registration what config file download from CUCM?


98- How many channels does E1 have? Framing and Signaling


99- What is VWIC2? What is the use of card type command?


100- In media resources use of “SCCP Local” and “DSP services dspfarm” command? Explain Transcoder, MTP and Conference


  Dif. b/w IOS Enhanced and Enhanced in CUCM?


  PRI-BACKHAUL in MGCP?


MGCP media negotiations.


  What port is used by MGCP gateway to communicate with CA?


  Directed call park and call park diff.


Ad-hoc and meet-me conference diff.


VirtualiZation for CUCM? Does CUCM 7.0 supports virtualization?


 Cisco Unity Connection Call Flow?


  How many voice mail port used in your company?


Inbound call matching dial-peer sequence.


  Default dial-peer disadvantages?


  COR List


  SIP Phone registration in CME


 Device pool mandatory fields?


RMCM in UCCX?


 Diff. b/w CTI RP and CTI Ports
 

DB replication types explain them
 

SIP PRACK message

What is SIP trunk and What is SIP Gateway?
 

IOS 12.4 and CUE 7.0 in CME router downloaded CUE 8.0 can CUE 7.0 access CUE 8.0 files
 

Adding custom ringtone in IP phone
 

CME IP Phone registration process with commands

ASA to ASA VPN




Cisco introduced IKE version 2 with ASA 8.4(x). This assumes we are configuring a tunnel using IKE version 1. (For version 2, both ends need to be running version 8.4(x) or greater).

IPSEC VPN's configured on this firewall?" Because if it's not already been done, you need to enable ISAKMP on the outside interface. To ascertain whether yours is on or off, issue a "show run crypto " command and check the results, if you do NOT see "crypto isakmp enable outside" or "crypto ikev1 enable outside" then you need to issue that command.

ASA-1# show run crypto
crypto ikev1 enable outside << Mines already enabled and its IKE version1
crypto ikev1 policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400

Step 1 : Create ACL to tell the ASA what is "Interesting traffic", that's traffic that it needs to encrypt.


 If you are running an ASA older than version 8.3(x) you will need to create a second access list to STOP the ASA performing NAT on the traffic that travels over the VPN.
Warning: (ASA Version 8.3 or older): If you already have NAT excluded traffic on the firewall (for other VPN's) this will BREAK THEM - to see if you do, issue a "show run nat" command, if you already have a nat (inside) 0 access-list {name} entry, then use that {name} NOT the one in my example.

So below I'm saying "Don't NAT Traffic from the network behind the ASA (10.254.254.0) that's going to network behind the VPN device at the other end of the tunnel (172.16.254.0).


ASA-1(config)#object network Site-A-SN
ASA-1(config-network-object)#subnet 10.254.254.0 255.255.255.0
ASA-1(config)#object network Site-B-SN
ASA-1(config-network-object)#subnet 172.16.254.0 255.255.255.0
ASA-1(config)#access-list VPN-INTERESTING-TRAFFIC line 1 extended permit ip object Site-A-SN object Site-B-SN
ASA-1(config)#nat (inside,outside) source static Site-A-SN Site-A-SN destination static Site-B-SN Site-B-SN no-proxy-arp route-lookup



Step 2. Create a "Tunnel Group" to tell the firewall its a site to site VPN tunnel "l2l", and create a shared secret that will need to be entered at the OTHER end of the site to site VPN Tunnel. I also set a keep alive value.


Note: Ensure the Tunnel Group Name is the IP address of the firewall/device that the other end of the VPN Tunnel is terminating on.

ASA-1(config)# tunnel-group 123.123.123.123 type ipsec-l2l
ASA-1(config)# tunnel-group 123.123.123.123 ipsec-attributes
ASA-1(config-tunnel-ipsec)# pre-shared-key 1234567890
ASA-1(config-tunnel-ipsec)# isakmp keepalive threshold 10 retry 2


Step 3. Create a policy that will setup how "Phase 1" of the VPN tunnel will be established, we have already put in a shared secret, this policy will make sure we use it. it also sets the encryption type (3DES), the hashing algorithm (SHA) and the Level of PFS (Group 2). Finally it sets the timeout before phase 1 needs to be re-established. It sets the timeout value to 86400 seconds (That's 1440 Minutes - or 24 hours )


ASA-1(config)# crypto ikev1 policy 10
ASA-1(config-ikev1-policy)#authentication pre-share
ASA-1(config-ikev1-policy)#hash sha
ASA-1(config-ikev1-policy)#group 2
ASA-1(config-ikev1-policy)#lifetime 86400


Step4  We stated above that we are going to use 3DES and SHA so we need a "Transform Set" that matches.


PetesASA(config)# crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac


Step 5 . Finally we need to create a "Cryptomap" to handle "Phase 2" of the VPN Tunnel, that also will use 3DES and SHA and PFS. And last of all we apply that Cryptomap to the outside interface.


ASA-1(config)# crypto map outside_map 1 match address VPN-INTERESTING-TRAFFIC
ASA-1(config)# crypto map outside_map 1 set pfs group2
ASA-1(config)# crypto map outside_map 1 set peer 123.123.123.123
ASA-1(config)# crypto map outside_map 1 set ikev1 transform-set ESP-3DES-SHA
ASA-1(config)# crypto map outside_map interface outside



Step 6 Don't forget to save your hard work with a "write mem" command.

ASA-1(config)# write mem
Building configuration...
Cryptochecksum: 5c8dfc45 ee6496db 8731d2d5 fa945425
8695 bytes copied in 3.670 secs (2898 bytes/sec)
[OK]
PetesASA(config)#



6. Simply configure the other end as a "Mirror Image" of this one.


ASA 5500 Site to Site VPN Copy and Paste Config

Note: This uses AES and SHA. It also assumes your outside interface is called 'outside'. Check! I've seen them called Outside (capital O), wan, and WAN.

crypto ikev1 enable outside
crypto ikev1 policy 10
authentication pre-share
encryption aes-256
hash sha
group 2
lifetime 86400
!
object network OBJ-MainSite
subnet 10.0.0.0 255.255.255.0
object network OBJ-RemoteSite
subnet 10.0.3.0 255.255.255.0
!
access-list VPN-INTERESTING-TRAFIC extended permit ip object OBJ-MainSite object OBJ-RemoteSite
nat (inside,outside) source static OBJ-MainSite OBJ-MainSite destination static OBJ-RemoteSite OBJ-RemoteSite no-proxy-arp route-lookup
!
tunnel-group 2.2.2.2 type ipsec-l2l
tunnel-group 2.2.2.2 ipsec-attributes
pre-shared-key 1234567
isakmp keepalive threshold 10 retry 2
!
crypto ipsec ikev1 transform-set VPN-TRANSFORM esp-aes-256 esp-sha-hmac
!
crypto map CRYPTO-MAP 1 match address VPN-INTERESTING-TRAFIC
crypto map CRYPTO-MAP 1 set pfs group2
crypto map CRYPTO-MAP 1 set peer 2.2.2.2
crypto map CRYPTO-MAP 1 set ikev1 transform-set VPN-TRANSFORM
crypto map CRYPTO-MAP interface outside
Simply change the values in red where;
  • 10.0.00 255.255.255.0 is the network behind the ASA you are working on.
  • 10.0.3.0 255.255.255.0 is the destination network behind the device you are connecting to.
  • 2.2.2.2 is the peer IP address of the device you are attempting to connect to.
  • 1234567 Is the shared secret you will use at both ends.